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Ismerkedés
A KOffice egy célzottan KDE környezet
alá írt, ennek könyvtárait és felhaszná-
lói felület-elemeit használó, abba illesz-
kedõ irodai alkalmazások gyûjtõneve.
Az irodai jelzõ gyakorlatilag azt jelenti,
hogy dokumentum-, kiadvány-,
bemutató-, kép- és grafikakészítéssel
kapcsolatos tevékenységek egységbe
kapcsolt eszközeirõl van szó. Ennek
az elvnek megfelelõen a KOffice

mindezekhez kapcsolódóan tartalmaz
eszközöket, illetve számos kiegészítõ
alkalmazást is.
Alapvetõ kérdés lehet az, hogy Linux

alatt elérhetõ irodai alkalmazások kö-
zött miért válassza valaki a KOffice-t
az említett jellegû feladatok elvégzésé-
re. A választás egyik oka természete-
sen a rendelkezésre álló eszközök és
képességek – amelyeket megpróbálok
bemutatni a továbbiakban. További ok
lehet a tökéletes illeszkedés a KDE

környezetbe, a felkínált eszközök sok-
rétûsége, a kezelhetõség, esetenként
akár az egyszerûség is. A választáskor
természetesen ugyanúgy tudnunk kell
az esetleges hiányosságokról, mint az
elõnyökrõl, így ezekrõl is igyekszünk
majd szót ejteni.
Ebben az írásban a KOffice 1.4.2 stabil
verzióját mutatjuk be, KDE 3.5.1 kör-
nyezet alatt. Az alkalmazás-csomag
konkrét telepítésére nem térünk ki
azért, mert gyakorlatilag minden
Linux disztribúció adott csomagkeze-
lõjével koffice név alatt megtalálható
és könnyedén telepíthetõ. A csomag
egyes elemei általában egyenként is
elérhetõk, telepíthetõk és használha-
tók. A KOffice elemei a következõk:
KWord – szövegszerkesztés, KSpread

és KChart – táblázat-kezelés és grafi-
kon vizualizáció, KPresenter – bemuta-
tó készítés, Kexi – adatbázis-kezelés,
ill. kiegészítõ alkalmazások: KFormula

– egyenlet-szerkesztés, Kivio – folya-
matábra készítés, Karbon14 – vektor-
grafikus rajz/grafika-készítés, Krita

– kép-manipulálás és egyszerû rajzo-
lás, Kugar – report/beszámoló készítés.

Szövegszerkesztés – KWord
A KWord egy olyan szövegszerkesztõ,
amely egyrészt minden hétköznapi
szövegszerkesztési elvárásnak képes
megfelelni, másrészt számos olyan
eszközt is tartalmaz, amellyel irodai
alkalmazás esetén lehet szükséges
ill. elvárható.
Új dokumentum létrehozásakor az
1. ábrához hasonló dialógus fogad,
amely a rendelkezésre álló dokumen-
tumsablonokat (template) kínálja fel,
ill. ezek mellett természetesen teljesen
új dokumentumot is készíthetünk. 
A KWord alapvetõ funkciói – a betû-,
szöveg-, bekezdés-, oldal-, lábjegyzet-,
fejléc-, tartalomjegyzék-, táblázatszer-
kesztési lehetõségek – azok, amelyeket
joggal elvárhatunk egy szövegszer-
kesztõ alkalmazástól, és ezek haszná-
lata ill. funkciói nem térnek el más
szövegszerkesztõ alkalmazások hason-
ló eszközeitõl, így ezekre részletesen
nem térünk ki. Az említett eszközök
a Format és a Table menükben érhetõk
el. A továbbiakban olyan funkciókra
és eszközökre koncentrálunk, amelyek
egyedivé teszik a KWord-öt mint szö-
vegszerkesztõt: frame-ek használata,

KOffice – irodai alkalmazás-család 
KDE alapokon (1. rész)

Szövegszerkesztés,
táblázatok, 
bemutatók

A KOffice a KDE grafikus asztali környezetbe illeszke-
dõ irodai alkalmazás-gyûjtemény. Néhol többet, néhol
kevesebbet nyújt mint más hasonló irodai csomagok.
A többi hasonló csomag véleményezését mellõzve,
megpróbáljuk bemutatni a KOffice lényeges képessé-
geit. A KOffice bemutatójának ezen elsõ részében
a csomag lelkét képezõ elemekre koncentrálok:
szövegszerkesztés, táblázatkezelés, bemutató készítés. 

©
 K

is
ka

p
u 

K
ft

. 
M

in
d

en
 jo

g
 f

en
nt

ar
tv

a



272006. ápriliswww.linuxvilag.hu

Alkalmazások

magas szintû integráltság és átjárható-
ság a KOffice más elemeivel, könnyen
használható irodai funkciók, támoga-
tott dokumentum-formátumok.
Van azonban a KWord-nek  olyan tulaj-
donsága, amely egyedivé és vonzóvá
teszi másokkal szemben. Egy ilyen
tulajdonság az úgynevezett frame-ek
használata. Gyakorlatilag egy KWord

dokumentumban minden tartalmi elem
egy frame része. Egy frame tartalmazhat
szöveget, képet, vagy akár más KOffice

alkalmazások által elõállított tartalmat:
táblázatot, folyamatábrát, grafikont, raj-
zot, stb. A frame-ek szabadon helyezhe-
tõk el a dokumentumon belül, ezáltal
a KWord olyan eszközt ad a kezünkbe,
amivel egyébként haladó kiadványszer-
kesztõ alkalmazásokban találkozhat-
nánk. A 2. ábrán illusztráljuk, hogy
a gyakorlatban ez mit is jelent: az olda-
lon szöveg található, alatta két szöveges
frame, a baloldaliban még egy egyenle-
tet tartalmazó úgynevezett formula

frame a jobboldaliban pedig egy képet
tartalmazó image frame látható. A kü-
lönféle frame-eket az alkalmazás balol-
dalán található Insert eszköztár illetve
az Insert menü segítségével helyezhe-
tünk el a dokumentumunkban.
Frame-eket használhatunk pl. arra is,
hogy könnyen kezelhetõ, változó mé-
retû, pozíciójú és alakú hasábokat hoz-
zunk létre. Ehhez csak létrehozunk
szöveges frame-eket (Insert->Text

frame) és összekapcsoljuk õket, amire
a létrehozáskor van lehetõség (3. ábra).
Ezzel szabad kezet kapunk a hasábok
elrendezéséhez és méretezéséhez.

A KWord a KDE-t használó ill. KDE-s
alkalmazásokat ismerõk körében nem
okoz meglepetést azzal, hogy a Kparts

technológiát használva jó példáját
hozza a KDE modularitásának:

a KOffice egyes alkalmazásainak funk-
ciói a KWord-bõl ugyanúgy elérhetõk
és kezelhetõk, mintha a megfelelõ
külsõ alkalmazásokat használnánk.
Például ha a dokumentumunkba egy

11..  áábbrraa Új dokumentum létrehozásakor
választhatunk a dokumentum
minták közül

22..  áábbrraa Néhány egyszerûbb frame elhelyezése egy dokumentumban, ill. egy másik KOffice
alkalmazás által létrehozandó új objektum-frame beszúrásának dialógusa

33..  áábbrraa Összekapcsolt szöveges frame-ek létrehozása, ami szabadformájú hasábos
szövegelrendezést tesz lehetõvé
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adatokat tartalmazó táblázatot szeret-
nénk illeszteni, akkor az Insert menü-
ben elérhetõ Object Frame-ek közül
a Spreadsheet-et választva a KOffice

táblázatkezelõjének (KSpread) minden
funkcionalitását elérhetjük a doku-
mentumunkban, ahogy ezt a 4/a. ábra

mutatja. De hasonlóképp, például
a KChart-tal grafikont illeszthetünk be
anélkül hogy elhagynánk a KWord-öt
(4/b. ábra).
Fontos hogy egy szövegszerkesztõ tud-
jon helyesírást ellenõrizni és javítani,
és erre a KWord-ben is van lehetõség.
Helyesírás-ellenõrzéshez az ispell vagy
aspell külsõ helyesírás-ellenõrzõket
használhatjuk, mindkettõhöz létezik
magyar szó-adatbázis (ispell-hu ill.
aspell-hu néven). KWord-ön belül az el-
lenõrzési tulajdonságokat a Settings-> 

Configure Kword->Spelling helyen
állíthatjuk be majd a Tools->Spellcheck

menüpontban vagy az eszköztáron
érhetjük el (5. ábra).
Szövegszerkesztõ alkalmazások irodai
funkciói közül egy fontos elem a kör-
levelek és beszámolók készítése. Míg
az utóbbiról késõbb lesz szó (mivel azt
egy külön KOffice alkalmazás, a Kugar

végzi), a körlevelek készítésérõl min-
denképpen szót kell ejtenünk.
A KWord-ben körlevelek készítése na-
gyon egyszerû feladat. Elõször el kell
döntenünk, hogy milyen adatforrást
használunk a körlevél adatainak táro-
lására/elérésére. A KWord lehetõséget
ad külsõ és belsõ adatforrás használa-
tára is. Külsõ adatforrás lehet egy
helyi vagy távoli SQL szerver, egy
KSpread táblázatkezelõvel elõállított
adatfájl, vagy a KDE címjegyzéke
(KAddressBook alkalmazás adatai).
Belsõ adatok esetén a bevitt adatok
magában a készülõ dokumentumban
kerülnek tárolásra. Az adatforrás kivá-
lasztása a Tools->Configure Mail

Merge menüpontban lehetséges.
Esetünkben a példa kedvéért egy
KSpread-ben készített táblázat tartal-
mazza a változó adatokat (kliensek
neve és címe). A táblázat létrehozása
után Configure Mail Merge->Open

Existing->KSpread Table Source-ot
választva megadjuk a létrehozott táb-
lázatfájl elérhetõségét, majd készít-
hetjük is a levelet. A táblák változó
adatainak beszúrását szerkesztés köz-
ben az Insert->Variable->Mail Merge

menüpontból végezhetjük. Az 6. ábra

egy példát mutat egy egyszerû
55..  áábbrraa Helyesírásellenõrzés KWord-ben

44//aa..  áábbrraa A KSpread táblázatkezelõ funkcióinak használata, amint Spreadsheet objektumot
szúrunk a dokumentumunkba

44//bb..  áábbrraa Illesszünk grafikont a dokumentumba a KChart eszközeivel 
a KWord-ön belül
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levélre, a táblázat adatival és az
elsõ oldal nyomtatási elõnézetével.
Egyes funkciók elrendezésének meg-
szokása egyes felhasználóknak okozhat
némi nehézséget, de gyorsan beleta-
nulhatunk, mivel rövid idõ alatt fel-
fedezhetõ az alkalmazott csoportosí-
tási rendszer. Például az oldalszám
– és más hasonló, változó értékû elem –
beillesztését az Insert->Variable->

Page->Page Number helyen tehetjük.
Ezúton hívom fel a kedves olvasó
figyelmét az Insert menü Variable

(változók) és Expression (kifejezések)
pontjaira, ahol számos hasonló jellegû
elemet találhatunk amelyek nagyban
megkönnyíthetik dokumentum-
szerkesztõi életünket.
A KWord számos fájl-formátumot
ismer és képes kezelni, a saját XML-
alapú formátuma mellett. Így használ-
hatunk OASIS OpenDocument,
OpenOffice, AmiPro, WordPerfect,
AbiWord, PDF, TeX, RTF, HTML,
SGML, WML formátumokat. Micro-

soft Word dokumentumokat a KWord

meg tud nyitni és olvasni, de a for-
mátum zártságának köszönhetõen
a bonyolultabb Word dokumentumok
konvertálásával elõfordulhatnak
gondok, ezért erre a célra lehetõleg
ne használjuk.
Ebben a rövid áttekintésben az volt
a cél, hogy néhány fontosabb funkciót
bemutassunk, amelyek a KWord-öt
leginkább jellemzik. A hétköznapi szö-
vegszerkesztõ-funkciók mellett ezek
olyan pluszt adhatnak, amelyek miatt
érdemes lehet a KWord használatának
a megfontolása. Szintén fontos hogy
a KWord – mint a KOffice csomag
legtöbb eleme – nagyon gyors: szinte
semmilyen funkcióra vagy eszközre

nem kell várni, minden azonnal törté-
nik. Hátrányok között meg kell emlí-
teni, hogy a KWord nem képes ver-
ziókövetésre és változtatások figyelé-
sére, nincs benne a Microsoft Word-
ben létezõ nyelvtani szabályok
alapján történõ ellenõrzés. Viszont
mindenképpen nagy elõny, hogy
aki ismeri a Word viselkedését képek
beszúrása után végzett nemkívánatos
automatikus átformázás esetenként
felmerülõ furcsaságait, azt meg kell

nyugtatnunk: a KWord esetén éppen
a frame-ek használata miatt ilyen
gondok nem merülnek fel.

Táblázatkezelés – KSpread
A KOffice táblázatkezelõ alkalmazása
a KSpread. Noha a KSpread a legtöbb
kezdõ és középhaladó felhasználó
számára elégséges funkcionalitást nyújt,
haladó és profi felhasználók számos
hiányosságot fognak felfedezni benne.
Mindazonáltal a legtöbb hétköznapi táb-
lázatkezelési alkalmazásra képes kielégí-
tõ megoldást adni. Így noha szimulációs
eszközökben hiányt szenved, számtalan
matematikai, statisztikai és gazdasági
függvényt találunk a KSpread-ben,
összesen több százat (7. ábra).
Függvények beszúrására az Insert->

Function menüponttal vagy az eszköz-
tár f(x) jelzésû gombjával van lehetõ-
ségünk. Minden függvényhez talá-
lunk leírást ami segíti azok használa-
tát. Gondot okozhat azonban, hogy
ha a cellákba rossz szintaxissal írjuk
be a kifejezéseinket, akkor semmilyen
segítséget vagy útmutatást nem
kapunk a hiba okáról, csupán egy
jelzést, hogy hibás a kifejezés.

66..  áábbrraa Körlevél készítésének elemei: a készülõ levél a változókkal, a táblázat a konkrét
adatokkal és az elsõ oldal nyomtatási elõnézete

77..  áábbrraa Számos beépített függvényt használhatunk
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Hétköznapi alkalmazások esetén
– ami leginkább adatok bemutatható
és kezelhetõ formába szervezését je-
lenti ill. ezekbõl grafikonok készítését
– a KSpread egy egyszerûen használ-
ható sokoldalú eszköznek bizonyul.
Fontos szempont lehet az is, hogy
a billentyûzet használata a más ha-
sonló alkalmazásokhoz szokott fel-
használók számára sem okoz nehézsé-
get, mivel a máshol is jól megszokott
billentyûparancsok többsége itt is
ugyanúgy használható.
Egyik fontos eszköz grafikonok ké-
szítése a rendelkezésre álló adatok-
ból. Erre az adat-tartomány kijelölése
után az Insert->Chart menüponttal

van lehetõségünk (8. ábra), amely
a KOffice csomag KChart nevû
grafikon-készítõ kiegészítõ-alkalma-
zásának elérését teszi lehetõvé a táb-
lázatkezelõn belül (ugyanúgy mint
KWord-ön belül). Kiválaszthatjuk
a grafikon típusát, beállíthatjuk para-
métereit (fontok, színek, elrendezés).
Sajnos a készíthetõ grafikonok típu-
sai eléggé korlátozottak, de így is
elegendõek a legtöbb ábrázolási
feladathoz és a készített grafikonok
látványosak.
Az adatok táblázat-szintû megjeleníté-
sének beállításaihoz számos cellafor-
mázási lehetõségünk van, a Format

menü elemeivel (elsõsorban a Cell

Format, 9. ábra), adatformátumot, hát-
teret, fontokat, színeket, kereteket ál-
líthatunk be könnyen.
Mint azt a KWord esetén már említet-
tük, a KOffice KParts alapokon nyug-
vó fejlesztésének köszönhetõen mind-
egyik KOffice alkalmazás elérhetõ
a többibõl. Így a KSpread-del készülõ
táblázatokba is beágyazhatók, például
rajzok, képek, szövegek.
KSpread-del importálhatunk Microsoft

Excel táblázatokat, de tudnunk kell,
hogy a Visual Basic makrókat nem ke-
zeli. Egyébként a KSpread számos for-
mátumot támogat a saját XML alapú
formátuma mellett: OASIS

OpenDocument, Excel, OpenOffice,
GNUmeric, PDF, TeX, HTML.

Bemutatók – KPresenter
A KPresenter egy olyan alkalmazás,
amely tökéletesen illeszkedik
a KOffice többi eleméhez: egyszerû,
gyors, praktikus. Egyszerû bemutatók

könnyedén és gyorsan összerakha-
tók a KPresenterrel. Új bemutató
létrehozásakor választhatunk a be-
épített vagy elõzõleg készített minták
közül (10. ábra) vagy készíthetünk
új bemutatót is.
A bemutatók slide-jaira az egyes
tartalmi elemek könnyen elhelyezhe-
tõk, az Insert menü számos pontjának
segítségével. A KPresenter-ben, ugyan-
úgy, mint mindegyik KOffice alkalma-
zásban, könnyen beilleszthetõk más
KOffice eszközzel készített objektu-
mok, de akár itt helyben a slide-on is
szerkeszthetõk és készíthetõk rajzok,
grafikonok, táblázatok, szöveges
elemek (11. ábra).

88..  áábbrraa Adatsorokból grafikon készítése: Insert->Chart menüpont. Grafikon stílusának
kiválasztása fent és a létrejött grafikon lent.

99..  áábbrraa Cellaformázási lehetõségek
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A bemutató slide-jai közötti átmenetek
beállítására is számos lehetõséget biz-
tosít a KPresenter, ezek a Slide Show

menüben érhetõk el (12. ábra).
Az Insert->Line és Insert->Shape
menüpontokban különféle vonalas
rajzokat és geometriai alakzatokat raj-
zolhatunk egyszerûen a bemutatóba.
Mindezek és a fenti tulajdonságok
mellett nincs viszont lehetõségünk
hangok és videók beillesztésére. 
Többek között KPresenter, OASIS

OpenDocument, OpenOffice pre-
zentációs formátumokba, HTML-be,
PDF-be és számos más formátumba

menthetjük el bemutatóinkat.
Megnyithatunk Microsoft PowerPoint

bemutatókat, viszont ha ez bonyolult,
animációkat, videókat tartalmaz, ak-
kor lehetnek gondok a konvertálással.
Mindent figyelembe véve,
a KPresenter kiváló eszköz animáci-
ók és videók nélkül készítendõ be-
mutatókhoz, különösen akkor, ha
a felhasznált adatok is KOffice alkal-
mazásokkal kerültek elõkészítésre.
Ha videók vagy animációk beillesz-
tésére van szükségünk akkor az
OpenOffice Impress vagy más bemuta-
tó-készítõ megfelelõbb választás lehet.

Összefoglaló
A KOffice-t bemutató sorozat elsõ
részében rövid betekintést próbáltam
adni a KWord, KSpread és KPresenter

eszközökkel történõ munka lehetõsé-
geibe. Noha egyes esetekben haladó
és profi felhasználók nagyobb tudá-
sú irodai alkalmazásokat fognak
elõnyben részesíteni (például
OpenOffice, StarOffice, esetleg Micro-

soft Office), a legtöbb esetben
a KOffice eszközei a hétköznapokban
jól és könnyen használható alternatí-
vákat kínálhatnak. A következõ rész-
ben a kiegészítõ alkalmazásoknak
szentelünk figyelmet: a Kexi adatbá-
zis-kezelõnek, a Kformula egyenlet-
szerkesztõnek, a Kivio folyamatábra
készítõnek, a Karbon és Krita grafikus
alkalmazásoknak és a Kugar beszá-
moló-készítõnek.

1100..  áábbrraa KPresenter új bemutató: alapértelmezett minták

1122..  áábbrraa Slide-ok közötti átmenetek beállítása, Slide Show->Edit Slide Transition menüpont

1111..  áábbrraa Készülõ bemutató egy slide-ja

KAPCSOLÓDÓ CÍMEK

� www.koffice.org

� www.koffice.org/kword

� www.koffice.org/kspread

� www.koffice.org/kpresenter

KKoovvááccss  LLeevveennttee

(leventek@gmail.com)

26 éves informatikus-
és villamosmérnök.
Évek óta használ kü-

lönféle Linux disztribúciókat. Fon-
tosnak tartja a nyílt forrású szoftve-
rek és fejlesztés elõnyeinek megis-
mertetését az emberekkel.
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